Dienstag, 23. Juli 2019

[Solution] Maven Proxy Issue - Maven not downloading artifacts - Maven behind Proxy

Your settings.xml - mine is in etc/maven/settings.xml on Linux - must look like:

<?xml version="1.0" encoding="UTF-8"?>
<!--
Licensed to the Apache Software Foundation (ASF) under one
or more contributor license agreements.  See the NOTICE file
distributed with this work for additional information
regarding copyright ownership.  The ASF licenses this file
to you under the Apache License, Version 2.0 (the
"License"); you may not use this file except in compliance
with the License.  You may obtain a copy of the License at

    http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing,
software distributed under the License is distributed on an
"AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
KIND, either express or implied.  See the License for the
specific language governing permissions and limitations
under the License.
-->

<settings
xmlns="http://maven.apache.org/SETTINGS/1.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0                                              http://maven.apache.org/xsd/settings-1.0.0.xsd">

<pluginGroups>
</pluginGroups>

<proxies>
</proxies>

<servers>

<server>
<id>myRepository</id>
<username>your user</username>
<password>your pw</password>
<configuration>
<httpConfiguration>
<all>
<usePreemptive>true</usePreemptive>
</all>
<settings>
</settings>
</httpConfiguration>
</configuration>
</server>

</servers>

<mirrors>

<mirror>
<id>myRepository</id>
<name>Proxy for XY</name>
<url>http://<maven proxy url></url>
<mirrorOf>*,!sonar</mirrorOf>
</mirror>
</mirrors>

<profiles>

</profiles>

</settings>




Keine Kommentare:

Kommentar posten

NEW BLOG! http://cleancode.consulting/

Dear Reader, This Blog is closed and remains as an archive. Please find our new Blog at  http://cleancode.consulting/